DialogBoxData Class


An object that is passed to your application when a dialog is displayed in Revit.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class DialogBoxData : APIObject
Visual Basic
Public Class DialogBoxData _
	Inherits APIObject
Visual C++
public ref class DialogBoxData : public APIObject

Remarks

When the application receives this object, a dialog has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

See Also