Get the total occupiable floor area represented by a mass instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The Document.
- massInstanceId
- Type: Autodesk.Revit.DB ElementId
The ElementId of the mass instance.
Return Value
The gross floor area in square feet.Remarks
The area is computed from the cross sections that are created by intersecting the associated Levels with the mass instance Geometry.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The ElementId massInstanceId is not a mass instance. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |