Validates shape to be stored in a DirectShape. Supercedes and extends IsValidGeometry().
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- shape
- Type: System.Collections.Generic IList GeometryObject
Shape to be validated represented as an array of objects.
Return Value
True if the supplied shape passes the validation criteria.Remarks
This function calls IsValidShape(GeometryObject) to validate each object in the list.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |