Creates a new instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- shouldApply
- Type: System Boolean
True if the settings should be applied, False if they should be set but not applied.
- lineColor
- Type: Autodesk.Revit.DB Color
The desired line color, which must be a valid color. Note that the fill color is calculated automatically from the line color so it is not advisable to use white, black, or shades of grey.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The lineColor argument does not represent a valid color. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |