ElementPhaseStatusFilter Class


A filter used to match elements that have a given phase status on a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public class ElementPhaseStatusFilter : ElementSlowFilter
Visual Basic
Public Class ElementPhaseStatusFilter _
	Inherits ElementSlowFilter
Visual C++
public ref class ElementPhaseStatusFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Inheritance Hierarchy

See Also