Checks whether a given cell, i.e. a box aligned with the XYZ axes, is inside, outside or on the border of the volume of interest.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- min
- Type: Autodesk.Revit.DB XYZ
The lower corner of the cell.
- max
- Type: Autodesk.Revit.DB XYZ
The upper corner of the cell.
Return Value
- -1 -- The cell is entirely rejected.
- 0 -- The cell partially belongs to the volume of interest. Use PrepareForCell() and TestPoint() to evaluate individual points.
- 1 -- The cell is fully accepted.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |