A chain of curves representing the centerline of the rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- adjustForSelfIntersection
- Type: System Boolean
If the curves overlap, as in a planar stirrup, this parameter controls whether they should be adjusted to avoid intersection (as in fine views), or kept in a single plane for simplicity (as in coarse views).
- suppressHooks
- Type: System Boolean
Identifies if the chain will include hooks curves.
- suppressBendRadius
- Type: System Boolean
Identifies if the connected chain will include unfilleted curves.
- multiplanarOption
- Type: Autodesk.Revit.DB.Structure MultiplanarOption
If the Rebar is a multi-planar shape, this parameter controls whether to generate only the curves in the primary plane (IncludeOnlyPlanarCurves), or to generate all curves, (IncludeAllMultiplanarCurves) including the out-of-plane connector segments as well as multi-planar copies of the primary plane curves. This argument is ignored for planar shapes.
- barPositionIndex
- Type: System Int32
An index between 0 and (NumberOfBarPositions-1). Use the barPositionIndex to obtain all the curves at a specific index in the distribution. You can use GetNumberOfBarPositions() to verify if a specific rebar has more than one bar positions. Use GetDistributionType() to probe if the bars in a specific rebar have a varying shape. If so, you can retrieve the centerline curve geometry of that particular bar, by passing the appropriate index. When the distribution type of a rebar set is uniform, the form of the bars does not vary from one index to another.
Return Value
The centerline curves or empty array if the curves cannot be computed because the parameters values are inconsistent with the constraints of the RebarShape definition.Remarks
If the Rebar is a set, meaning GetLayoutRule() does not return Single, this method returns the first rebar in the set, even if the first bar is suppressed by IncludeFirstBar being false.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- A value passed for an enumeration argument is not a member of that enumeration |