Returns the 3D point at the start or end of this curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- index
- Type: System Int32
0 for the start or 1 for end of the curve.
Return Value
The curve endpoint.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | curve is unbound and does not have start and end points. -or- index must be 0 for the start of the curve or 1 for the end. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |