Sets the categories admitted by this filter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categories
- Type: System.Collections.Generic ICollection ElementId
Remarks
Testing that an element's category is a member of this set is, essentially, the first rule of the filter.
Changing the set of categories will clear the element's filter rules.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |