Indicates if the stairs is created by stairs components(runs, landings and supports).
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- stairsId
- Type: Autodesk.Revit.DB ElementId
The stairs element to check.
Return Value
True if the stairs is created by components, False otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element stairsId does not exist in the document |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |