The Document Creation object is used to create new instances of elements within the Autodesk Revit project.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
The Document Creation object is a utility object that is used to create new instances of elements within the Autodesk Revit project. This object, available from the Document.Create property should be used to create elements instead of using New. This object ensures that the elements created are added to the document correctly.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.Creation ItemFactoryBase
Autodesk.Revit.Creation Document
Autodesk.Revit.DB APIObject
Autodesk.Revit.Creation ItemFactoryBase
Autodesk.Revit.Creation Document