Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- frameOfReference
- Type: Autodesk.Revit.DB Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the surface of revolution.- The frame can be "right-handed" or "left-handed".
- The origin of the frame is the base of point of the axis of revolution.
- The BasisZ of the frame is the direction of the axis.
- profileCurve
- Type: Autodesk.Revit.DB Curve
The profile curve.
Return Value
True if the profile curve is valid; False otherwise.Remarks
The validity is defined as follows:
- The profile curve is bounded and non-degenerate.
- It is co-planar with the axis of revolution.
- It lies on the xz plane of the frame.
- It lies on the right side of the axis.
- Only the end points of the profile curve can touch the axis.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |