ReferenceIntersector Constructor (View3D)


Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public ReferenceIntersector(
	View3D view3d
)
Visual Basic
Public Sub New ( _
	view3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
	View3D^ view3d
)

Parameters

view3d
Type: Autodesk.Revit.DB View3D
The view in which to find references.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException View cannot be a template view.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also