Test the category id to make sure it is indeed a top-level built-in category.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryId
- Type: Autodesk.Revit.DB ElementId
Category id to be tested.
- doc
- Type: Autodesk.Revit.DB Document
Document to look up the category by id.
Return Value
False unless categoryId corresponds to a valid built-in top-level model category.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |