AddSite Method


Adds a site (IfcObject) handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public void AddSite(
	IFCAnyHandle siteHandle
)
Visual Basic
Public Sub AddSite ( _
	siteHandle As IFCAnyHandle _
)
Visual C++
public:
void AddSite(
	IFCAnyHandle^ siteHandle
)

Parameters

siteHandle
Type: Autodesk.Revit.DB.IFC IFCAnyHandle
The site handle.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also