Appends the collection of Geometry objects into the model or view specific shape representation stored in this DirectShape. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pGeomArr
- Type: System.Collections.Generic IList GeometryObject
Shape expressed as a collection of Geometry objects.
- viewType
- Type: Autodesk.Revit.DB DirectShapeTargetViewType
Passing DirectShapeTargetViewType.Default as view type will cause the default shape to be appended.
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |