TripleProduct Method


The triple product of this vector and the two specified vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public double TripleProduct(
	XYZ middle,
	XYZ right
)
Visual Basic
Public Function TripleProduct ( _
	middle As XYZ, _
	right As XYZ _
) As Double
Visual C++
public:
double TripleProduct(
	XYZ^ middle, 
	XYZ^ right
)

Parameters

middle
Type: Autodesk.Revit.DB XYZ
The second vector.
right
Type: Autodesk.Revit.DB XYZ
The third vector.

Return Value

The real number equal to the triple product.

Remarks

The scalar triple product is defined as the dot product of one of the vectors with the cross product of the other two. Geometrically, this product is the (signed) volume of the parallelepiped formed by the three vectors given.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when middle or right is a null reference ( Nothing in Visual Basic) .

See Also