Create Method


Creates a new instance of a single flat Fabric Sheet element within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2015

Syntax

C#
public static FabricSheet Create(
	Document document,
	Element hostElement,
	ElementId fabricSheetTypeId
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	hostElement As Element, _
	fabricSheetTypeId As ElementId _
) As FabricSheet
Visual C++
public:
static FabricSheet^ Create(
	Document^ document, 
	Element^ hostElement, 
	ElementId^ fabricSheetTypeId
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document in which the fabric sheet is to be created.
hostElement
Type: Autodesk.Revit.DB Element
The element that will host the FabricSheet. The host can be a Structural Floor, Structural Wall, Structural Slab, or a Part created from a structural layer belonging to one of those element types.
fabricSheetTypeId
Type: Autodesk.Revit.DB ElementId
The id of the FabricSheetType.

Return Value

The newly created single Fabric Sheet instance.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The element hostElement was not found in the given document. -or- The host Element is not a valid host for Fabric Sheet. -or- fabricSheetTypeId should refer to an FabricSheetType element.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.

See Also