SetFromRebar Method


Set an instance of a RebarContainerItem element according to a Rebar parameters.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2016

Syntax

C#
public void SetFromRebar(
	Rebar rebar
)
Visual Basic
Public Sub SetFromRebar ( _
	rebar As Rebar _
)
Visual C++
public:
void SetFromRebar(
	Rebar^ rebar
)

Parameters

rebar
Type: Autodesk.Revit.DB.Structure Rebar
The Rebar.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The RebarShape of rebar has End Treatments
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.

See Also