SetFromRebar Method


Rebar Container Item Set From Rebar Method

Set an instance of a RebarContainerItem element according to a Rebar parameters. Will throw exception if given rebar is not shape driven. Will throw exception if given rebar has moved bars in set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetFromRebar(
	Rebar rebar
)

Parameters

rebar Rebar
The Rebar.
Exceptions
Exception Condition
ArgumentException Can't create container from Rebar with moved bars. -or- Can't create container from Rebar which has excluded bars other than the first and last one. -or- A RebarContainerItem cannot be created from a Free Form Rebar or from a Shape Driven Rebar whose Rebar Shape has End Treatments or Cranks or terminations' rotation angles are different than 0.
ArgumentNullException A non-optional argument was null
See Also