ElementStructuralTypeFilter Class


A filter used to find elements matching a structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public class ElementStructuralTypeFilter : ElementQuickFilter
Visual Basic
Public Class ElementStructuralTypeFilter _
	Inherits ElementQuickFilter
Visual C++
public ref class ElementStructuralTypeFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

See Also