Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type. Shape of this object expressed as a collection of Geometry objects
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- shape
- Type: System.Collections.Generic IList GeometryObject
- viewType
- Type: Autodesk.Revit.DB DirectShapeTargetViewType
The view type this shape is intended for.
Return Value
True if the supplied shape passes the validation criteria.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |