Creates a new instance of a piping system and adds it to the document.
Namespace:
Autodesk.Revit.DB.Plumbing
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADocument
-
Type:
Autodesk.Revit.DB
Document
The document where the element will be created and added.
- typeId
-
Type:
Autodesk.Revit.DB
ElementId
The identifier of this piping system element's type.
Return Value
The newly created piping system element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The typeId is not an element id for a valid piping system type. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |