DialogId Property


A unique string identifier for DialogBox and TaskDialog type dialogs in Revit.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2017

Syntax

C#
public string DialogId { get; }
Visual Basic
Public ReadOnly Property DialogId As String
	Get
Visual C++
public:
property String^ DialogId {
	String^ get ();
}

Remarks

DialogBox: The unique string ID that can be used to uniquely identify those types of dialogs. TaskDialog: The customed string if TaskDialog.Id is set, empty string for default TaskDialog.Show() Standard Message Boxes: Empty string ID.

See Also