Creates a new placeholder pipe.
Namespace:
Autodesk.Revit.DB.Plumbing
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
The document.
- systemTypeId
-
Type:
Autodesk.Revit.DB
ElementId
The ElementId of the piping system type.
- pipeTypeId
-
Type:
Autodesk.Revit.DB
ElementId
The ElementId of the pipe type.
- levelId
-
Type:
Autodesk.Revit.DB
ElementId
The level id for the pipe.
- startPoint
-
Type:
Autodesk.Revit.DB
XYZ
The first point of the placeholder line.
- endPoint
-
Type:
Autodesk.Revit.DB
XYZ
The second point of the placeholder line.
Return Value
The placeholder pipe.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The systemTypeId is not valid piping system type. -or- The pipe type pipeTypeId is not valid pipe type. -or- The level id levelId is not valid. -or- The points of startPoint and endPoint are equal. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |