Creates a new placeholder pipe.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- systemTypeId
- Type: Autodesk.Revit.DBElementId
The ElementId of the piping system type.
- pipeTypeId
- Type: Autodesk.Revit.DBElementId
The ElementId of the pipe type.
- levelId
- Type: Autodesk.Revit.DBElementId
The level id for the pipe.
- startPoint
- Type: Autodesk.Revit.DBXYZ
The first point of the placeholder line.
- endPoint
- Type: Autodesk.Revit.DBXYZ
The second point of the placeholder line.
Return Value
The placeholder pipe.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The systemTypeId is not valid piping system type. -or- The pipe type pipeTypeId is not valid pipe type. -or- The ElementId levelId is not a Level. -or- The points of startPoint and endPoint are too close: for MEPCurve, the minimum length is 1/10 inch. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsDisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |