GetPointLineZone Method (UV, UV)


Gets the index of fill grid line and the point on the grid line nearest to the input point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public int GetPointLineZone(
	UV point,
	out UV nearestPoint
)
Visual Basic
Public Function GetPointLineZone ( _
	point As UV, _
	<OutAttribute> ByRef nearestPoint As UV _
) As Integer
Visual C++
public:
int GetPointLineZone(
	UV^ point, 
	[OutAttribute] UV^% nearestPoint
)

Parameters

point
Type: Autodesk.Revit.DB UV
Input point.
nearestPoint
Type: Autodesk.Revit.DB UV %
The point on the grid line nearest to the input point.

Return Value

The index of fill grid line.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also