HelpId Property


An ID that represents the dialog that has been displayed.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2010

Syntax

C#
[ObsoleteAttribute("This property has been deprecated since Revit 2017. Use DialogId instead.")]
public int HelpId { get; }
Visual Basic
<ObsoleteAttribute("This property has been deprecated since Revit 2017. Use DialogId instead.")> _
Public ReadOnly Property HelpId As Integer
	Get
Visual C++
[ObsoleteAttribute(L"This property has been deprecated since Revit 2017. Use DialogId instead.")]
public:
property int HelpId {
	int get ();
}

Remarks

Use this ID within your application to key suitable responses for the dialog. Note: this id is not guaranteed to remain stable for different builds of Autodesk Revit.

See Also