Face Class


A bounded face of a 3d solid or open shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)

Syntax

C#
public class Face : GeometryObject
Visual Basic
Public Class Face _
	Inherits GeometryObject
Visual C++
public ref class Face : public GeometryObject

Remarks

Faces are defined by surfaces ( Surface ) bounded by edge loops. The surfaces provide natural UV parameterization to the faces.

Inheritance Hierarchy

See Also