Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- reference
- Type: Autodesk.Revit.DB Reference
The family instance reference.
Return Value
Returns the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. Returns FamilyInstanceReferenceType.NotAReference if the instance reference doesn't correspond to a reference plane or line in the family.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |