Returns the array of pairs [parameter ID, length] that correspond to segments of a bent fabric sheet (like A, B, C, D etc.).
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rounded
- Type: System Boolean
Set to true to return rounded values for segments lengths.
Return Value
Array of pairs [parameter ID, length] that correspond to segments of a bent fabric sheet (like A, B, C, D etc.) is returned for bend fabric sheet. For flat fabric sheet (not bent) empty array is returned.Remarks
This method does not provide alphabetical nor any other order of returned parameters.
Examples

private void GetBentFabricSheetData(FabricSheet fabricSheet)
{
string fabricNumber = fabricSheet.FabricNumber;
IDictionary<ElementId, double> idsAndLengths = fabricSheet.GetSegmentParameterIdsAndLengths(true);
StringBuilder displayInfo = new StringBuilder();
displayInfo.AppendLine(string.Format("Parameter Ids and segment lengths for FabricSheet {0}:", fabricNumber));
foreach (ElementId key in idsAndLengths.Keys)
{
displayInfo.AppendLine(string.Format("Parameter Id: {0}, Length: {1}", key, idsAndLengths[key]));
}
TaskDialog.Show("Revit", displayInfo.ToString());
}

Private Sub GetBentFabricSheetData(fabricSheet As FabricSheet)
Dim fabricNumber As String = fabricSheet.FabricNumber
Dim idsAndLengths As IDictionary(Of ElementId, Double) = fabricSheet.GetSegmentParameterIdsAndLengths(True)
Dim displayInfo As New StringBuilder()
displayInfo.AppendLine(String.Format("Parameter Ids and segment lengths for FabricSheet {0}:", fabricNumber))
For Each key As ElementId In idsAndLengths.Keys
displayInfo.AppendLine(String.Format("Parameter Id: {0}, Length: {1}", key, idsAndLengths(key)))
Next
TaskDialog.Show("Revit", displayInfo.ToString())
End Sub