Gets all the levels the given stairs group placed on.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- stairs
- Type: Autodesk.Revit.DB.Architecture Stairs
A stairs element in this multistory stairs element.
Return Value
The ids of base levels of the given stairs in this multistory stairs.Remarks
If a stairs element is a stairs group, it gets all the base levels of each member of the group; If a stairs element is an individual stairs, it just gets the base level of the stairs element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input stairs is not a member of this multistory stairs. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |