GetWorkset Method (WorksetId)


Returns the workset from a input WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public Workset GetWorkset(
	WorksetId id
)
Visual Basic
Public Function GetWorkset ( _
	id As WorksetId _
) As Workset
Visual C++
public:
Workset^ GetWorkset(
	WorksetId^ id
)

Parameters

id
Type: Autodesk.Revit.DB WorksetId
Id of a workset.

Return Value

The returned workset. a null reference ( Nothing in Visual Basic) if there is no workset in this table with this Id.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also