ElementDesignOptionFilter Constructor (ElementId, Boolean)


Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public ElementDesignOptionFilter(
	ElementId designOptionId,
	bool inverted
)
Visual Basic
Public Sub New ( _
	designOptionId As ElementId, _
	inverted As Boolean _
)
Visual C++
public:
ElementDesignOptionFilter(
	ElementId^ designOptionId, 
	bool inverted
)

Parameters

designOptionId
Type: Autodesk.Revit.DB ElementId
The design option id to match.
inverted
Type: System Boolean
True if the filter should match all elements which are not contained within a particular design option.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also