IsTypeValidForSlot Method


Determines whether instance of given family type can be used in the component repeater slot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public bool IsTypeValidForSlot(
	ElementId typeId
)
Visual Basic
Public Function IsTypeValidForSlot ( _
	typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsTypeValidForSlot(
	ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB ElementId
The element id of the type.

Return Value

True if the family type can be used in the component repeater slot.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also