GetCenterPointsForConnectedGridCellsInSpaceVolume Method


Returns the collection of connected cells in an enclosed space volume.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public IList<XYZ> GetCenterPointsForConnectedGridCellsInSpaceVolume(
	int spaceVolume
)
Visual Basic
Public Function GetCenterPointsForConnectedGridCellsInSpaceVolume ( _
	spaceVolume As Integer _
) As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ GetCenterPointsForConnectedGridCellsInSpaceVolume(
	int spaceVolume
)

Parameters

spaceVolume
Type: System Int32

Return Value

The center points for the connected analytical grid cells in the enclosed space volume.

Remarks

This method requires the building envelope analyzer method created with the option set to compute enclosed space volumes.

See Also