ElementCategoryFilter Constructor (ElementId)


Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public ElementCategoryFilter(
	ElementId categoryId
)
Visual Basic
Public Sub New ( _
	categoryId As ElementId _
)
Visual C++
public:
ElementCategoryFilter(
	ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB ElementId
The category id to match.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The category was not valid for filtering.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also