Convert Method


Converts the set of MEP design elements into fabrication parts.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017

Syntax

C#
public DesignToFabricationConverterResult Convert(
	ISet<ElementId> selection,
	int serviceId
)
Visual Basic
Public Function Convert ( _
	selection As ISet(Of ElementId), _
	serviceId As Integer _
) As DesignToFabricationConverterResult
Visual C++
public:
DesignToFabricationConverterResult Convert(
	ISet<ElementId^>^ selection, 
	int serviceId
)

Parameters

selection
Type: System.Collections.Generic ISet ElementId
The set of element identifiers to convert from MEP design elements to fabrication parts.
serviceId
Type: System Int32
The identifier of the fabrication service.

Remarks

After this method has been invoked, call:

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException the selection contains invalid elements to convert. -or- the specified fabrication service is not valid for all domains in the selection.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException no fabrication configuration is loaded.

See Also