GuidEnum Constructor


Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public GuidEnum(
	Guid guid
)
Visual Basic
Public Sub New ( _
	guid As Guid _
)
Visual C++
public:
GuidEnum(
	Guid guid
)

Parameters

guid
Type: System Guid
The GUID of this GUID-based enum.

See Also