SelectableInViewFilter Class


A filter that passes elements that are selectable in the given view.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public class SelectableInViewFilter : ElementSlowFilter
Visual Basic
Public Class SelectableInViewFilter _
	Inherits ElementSlowFilter
Visual C++
public ref class SelectableInViewFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded. This filter is designed to operate on a list of elements visible in the given view. This can be obtained from a FilteredElementCollector constructed with the view id. This filter may not correctly restrict elements which are not a part of the visible elements of the view.

Inheritance Hierarchy

See Also