Sets the handles representing the cardinal directions in 2D.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- positive
- Type: System Boolean
True if the handles returned should be in the positive direction, false if the handles should be in the negative direction.
- xDir
- Type: Autodesk.Revit.DB.IFC IFCAnyHandle
The X direction handle.
- yDir
- Type: Autodesk.Revit.DB.IFC IFCAnyHandle
The Y direction handle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |