IsRenderingSupported Method


Checks if 3D view rendering is currently supported in the running instance of Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014 UR1

Syntax

C#
public static bool IsRenderingSupported()
Visual Basic
Public Shared Function IsRenderingSupported As Boolean
Visual C++
public:
static bool IsRenderingSupported()

Return Value

Returns True if rendering is currently supported, False otherwise.

Remarks

A typical reason for rendering not being enabled is when rendering and material libraries are not currently available in the installed copy of Revit.

See Also