Get all elements that, from a logical point of view, are the children of this Element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filter
- Type: Autodesk.Revit.DB ElementFilter
What type of elements we are interested of.
Return Value
Logical children of this element.Remarks
The elements that this method will return:
- Will be deleted if the input Element is deleted.
- Potentially could report the input Element as a host (there could be other type of parent/child relationship here: for example view/view-specific elements, etc.)
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |