Inserts a triangle into the stream and associated buffer.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- triangle
- Type: Autodesk.Revit.DB.DirectContext3D IndexTriangle
The triangle to be inserted.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space. |