Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ccda
- Type: Autodesk.Revit.DB Document
The Document.
- typeEnum
- Type: Autodesk.Revit.DB.Analysis ConceptualConstructionWindowSkylightType
The ConceptualConstructionWindowSkylightType to get the ConceptualConstructionType for.
Return Value
Returns ElementId of a ConceptualConstructionType.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionWindowSkylightType. -or- A value passed for an enumeration argument is not a member of that enumeration |