GetGraphicOverrides Method (WorksetId)


Returns the graphic overrides assigned to elements in a particular workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public WorksharingDisplayGraphicSettings GetGraphicOverrides(
	WorksetId worksetId
)
Visual Basic
Public Function GetGraphicOverrides ( _
	worksetId As WorksetId _
) As WorksharingDisplayGraphicSettings
Visual C++
public:
WorksharingDisplayGraphicSettings^ GetGraphicOverrides(
	WorksetId^ worksetId
)

Parameters

worksetId
Type: Autodesk.Revit.DB WorksetId
The workset id of interest. This must be a user workset.

Return Value

Returns the graphic overrides assigned to the workset.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException worksetId does not correspond to a user workset in the document containing this WorksharingDisplaySettings.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also