LineStyle Property


The line style of this curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)

Syntax

C#
public Element LineStyle { get; set; }
Visual Basic
Public Property LineStyle As Element
	Get
	Set
Visual C++
public:
property Element^ LineStyle {
	Element^ get ();
	void set (Element^ value);
}

Remarks

The return of this property will be a [!:Autodesk::Revit::DB::GraphicsStyle] element. These graphics styles should be associated to subcategories of the BuiltInCategory OST_Lines.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when argument is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions InvalidOperationException Thrown when regeneration failed. -- or -- Thrown when fail to get line style.

See Also