SetTransform Method


Sets the origin of the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public void SetTransform(
	Transform trf
)
Visual Basic
Public Sub SetTransform ( _
	trf As Transform _
)
Visual C++
public:
void SetTransform(
	Transform^ trf
)

Parameters

trf
Type: Autodesk.Revit.DB Transform
Transform to be set.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentsInconsistentException trf is not a rigid body transformation.

See Also