Get the id of the Rebar Coupler that is applied to the rebar at the specified end.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2009
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- end
- Type: System Int32
0 for the start Rebar Coupler, 1 for the end Rebar Coupler.
Return Value
The id of a Rebar Coupler, or invalidElementId if the rebar has no Rebar Coupler at the specified end.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | end must be 0 or 1. |