Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2017
Syntax
Remarks
- 1. The distribution type ( [!:Autodesk::Revit::DB::Rebar::distributionType] ) of the Rebar is DistributionType::Enum::VaryingLength.
- 2. There are at least two bars within the Rebar set that have different shape parameter values (i.e at least two bars vary in length).
The shape parameters of a Rebar can be accessed via [!:Autodesk::Revit::DB::Structure::RebarShapeDefinition::getParameters] method.
The parameters at a specific index in a Rebar set can be accessed via [!:Autodesk::Revit::DB::Structure::Rebar::getParameterValueAtIndex] method.
If this property is true, then the Revit numbering mechanism ( [!:Autodesk::Revit::DB::NumberingSchema] ) will assign each bar, in a varying set, a number. The number is assigned based on the Revit numbering logic. (For example if two bars are identical, they will receive the same number). The numbering mechanism will compare varying bars with other varying or uniform bars within the project. (i.e each bar in a varying set is interpreted as an individual Rebar).
If this property is false, the following happens:- 1. The Revit numbering mechanism ( [!:Autodesk::Revit::DB::NumberingSchema] ) will assign a unique number for each varying Rebar set. Each bar within the varying set will have(share) the same number that was assigned for the entire set. Even if two varying Rebar sets are identical, they will be assigned different numbers.
- 2. Each bar within a varying set will also be assigned a suffix parameter (REBAR_NUMBER_SUFFIX). This suffix parameter will receive values based on the RebarVaryingLengthNumberSuffix property.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |